Scheduled for April 10, 2024 at 7:00 AM – 7:30 AM
Affects
Send & Track
Under maintenance from 7:00 AM to 7:30 AM
Labelling
Under maintenance from 7:00 AM to 7:30 AM
Completed
April 10, 2024 at 7:30 AMCompleted
April 10, 2024 at 7:30 AMMaintenance has completed successfully
In progress
April 10, 2024 at 7:00 AMIn progress
April 10, 2024 at 7:00 AMMaintenance is now in progress
Planned
April 10, 2024 at 7:00 AMPlanned
April 10, 2024 at 7:00 AMPer 10 april, the application for the generation of shipping labels will be upgraded. As a result, Printertype-responses in the categy Zebra|Generic ZPL II have adjustments in the buildup of the ZPL-code. This change affects users of the shipment- or Labelling-API who utilize the Zebra-printertypes and add extra ZPL commands to the API output. These customers may face compatibility issues due to the revised output structure. Users of this output type are advised to evaluate the ZPL-output on compatibility with application(s) and/or hardware.
Adjustments to the ZPL output are as follows:
The resolution command (^JM) is now set within a label format (^XA, ^XZ block)
The documentation command (^FX) containing the form name is no longer generated.
The ZPL header value in the default configuration file was changed to an empty value instead of "^MMT". If the original value (^MMT) is used, it is replaced by "^XA^MMT^XZ" to match the ZPL reference.
Some ZPL commands like (^LS, ^LT etc.) are now generated only once before the first label and no longer on every label.
The new Zebra|Generic output-types are retrievable via the sandbox-environment of either Labelling- or Shipment-API.
Note that PostNL discourages enriching the shipping-labels with extra ZPL-code. However, understanding that some of our customers might still proceed with such modifications, and since we cannot identify these instances directly, we are proactively reaching out as an additional measure of caution.